Internet Worm Protection features

Internet Worm Protection prevents incoming network worms and other Internet threats from attacking your computer. A worm is a self-contained program that can replicate itself over a computer network. Internet Worm Protection can detect a worm on the network before it copies itself onto your computer.

Internet Worm Protection uses the following features to detect and handle incoming worms and Internet attacks:

Port blocking | Blocks incoming worm activity.
Trojan horse detection | Detects connection attempts on ports that are commonly used by Trojan horse applications. If the connection matches a Trojan Horse rule, Internet Worm Protection issues an alert.
Auto blocking | Blocks repeated Internet attacks. When Internet Worm Protection detects an attack, it automatically blocks any further communication from the attacker's IP address for 30 minutes. Customizing AutoBlock
General rules | Uses a set of rules to monitor and handle all traffic and applications on the network. These rules control how Internet Worm Protection guards your computer from malicious incoming traffic, programs, and Trojan horses. Customizing General Rules
Traffic analysis | Monitors network traffic for malicious activity. If Internet Worm Protection detects such activity, it blocks the traffic, logs the event, and issues an alert.
Exploit detection | Prevents another computer from exploiting defects in your computer's software. Worms use these defects to transfer infected files onto your computer.
Threat level | Scans an application for known viruses, and determines whether a program is malicious.

More Information

About Internet Worm Protection options